Zyxel Deutschland Forum - Herzlich Willkommen!

Für Support Anfragen nutzen Sie http://support.zyxel.eu oder als Fachhändler http://partner.zyxel.eu
Aktuelle Zeit: Donnerstag 19. Juli 2018, 15:14

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]



 

Forumsregeln


Verehrte Kunden von ZyXEL!

Dieses Forum, ist ein Community Forum "Kunden helfen Kunden".

Wenn Sie einen Fehler in den Produkten von ZyXEL gefunden haben, der sich eindeutig nachstellen lässt, melden Sie diesen bitte dem deutschen ZyXEL Support unter diesem Formular:

http://www.zyxel.com/de/de/support/support_feedback_de.shtml

Wenn Sie ZyXEL Partner sind, können Sie gerne unseren Premium Support kontaktieren.

Wir danken Ihnen und wünschen Ihnen weiterhin viel Spaß mit Ihrem ZyXEL Produkt.



Ein neues Thema erstellen Auf das Thema antworten  [ 16 Beiträge ]  Gehe zu Seite 1, 2  Nächste
Autor Nachricht
 Betreff des Beitrags: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Montag 12. März 2018, 18:00 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Vorbemerkung: http://www.zyxelforum.de/viewtopic.php?f=195&t=9925&p=65547&hilit=cifs habe ich durchgelesen, aber es hilft mir nicht weiter.

Mein NAS hat die Firmware-Version V5.21(AAZF.1) und die App "NFS" ist schon lange installiert. Es ist mir noch nie gelungen, einen Share anzulegen, obwohl ich es schon mit vielen Namen versucht habe. Die Übersichtsliste aller Share ist immer leer. Der letzte Versuch ging so:
  • Name: DIA
  • 192.168.192.0/24 ist der Netzwerkzweig, in dem alle Shares sichtbar sein sollen.Das NAS selbst befindet sich im gleichen Zweig.
  • Der dritte Bildschirm bestätigt meine eingegebenen Daten.
  • Wenn ich dann auf "Übernehmen" klicke kommt wieder die leere Liste von Shares.
:wand:
Bemerkenswert ist, daß schon einmal benützte Namen kein zweites Mal benützt werden können; es müssen also doch irgendwelche Spuren meiner Versuche verblieben sein; langsam gehen mir die sinnvollen Namen aus.

FTP und Samba funktionieren übrigens einwandfrei.
:hilfe: Ich stehe im dunklen finsteren Wald.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Dienstag 13. März 2018, 10:43 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
ebbi97a hat geschrieben:
Bemerkenswert ist, daß schon einmal benützte Namen kein zweites Mal benützt werden können; es müssen also doch irgendwelche Spuren meiner Versuche verblieben sein; langsam gehen mir die sinnvollen Namen aus.

Alles ist noch viel schlimmer! Gestern Abend habe ich zufälligerweise ein Experimentiersystem angeworfen und dort mit dem Netzwerk herumgespielt; dabei fand ich folgendes:
Dateianhang:
Bildschirmfoto_2018-03-12_21-40-07.png

  • Diese unsichtbaren NFS-Shares scheinen also wirklich zu existieren und zwar ganz viele, wie man in der kleinen Liste auf der rechten Seite des Bildes sieht.
  • Was dem widerspricht sieht man ganz links oben: dort wird der vermeintliche NFS-Share mit smb: statt mit nfs: eingebunden.
Darüber mußte ich erst mal eine Nacht schlafen.

Weil man mit so einem Blödsinn sich ja nur blamieren kann, habe ich heute früh mein Produktivsystem (Xubuntu 16.04) hergonommen, wo seit langer Zeit bereits ein NFS-Server (NFSv4 von einem Debian-System) eingebunden ist, der einwandfrei funktioniert. Der relavante Teil meiner /etc/fstab aus dem Xubuntu lautet:
Code:
# NFS:
2i1800:/arc-o   /2I1800/arc-o   nfs4   rw   0   0
2i1800:/arc-p   /2I1800/arc-p   nfs4   rw   0   0
2i1800:/arc-x   /2I1800/arc-x   nfs4   rw   0   0
nas326:/DIA   /NAS326/DIA   nfs4   ro   0   0
#nas326:/nfs   /NAS326/nfs   nfs4   rw   0   0

2i1800 ist der Debian-Server, wo alles funktioniert. Wenn ich auf dem NAS (nas326) den Dienst aktiviere, sehe ich im "Status Center" folgendes:
Dateianhang:
Bildschirmfoto_2018-03-13_08-00-45--nfsd-NAS326.png

Der nfsd läuft ganze 3 Mal! Verstehe ich nicht. In der Anzeige im NAS bleiben aber sowohl die Liste der Shares als auch die Liste der Verbindungen leer:
Dateianhang:
Bildschirmfoto_2018-03-13_09-27-13.png

Weiter geht's mit Xubuntu: Dort sind zwei Shares importiert -- zumindest zeigt sie der Dateimanager an. 2 Shares sind zu sehen und eingehängt:
Dateianhang:
Bildschirmfoto_2018-03-13_09-31-20.png

Der Share DIA (worin tausende von Bildern sein sollten) ist leer, während der Share nfs (von dem ich nicht einmal weiß wer ihn angelegt hat und wie er entstanden ist!) enthält ein paar Bilder (welche allerdings von mir stammen):
Dateianhang:
Bildschirmfoto_2018-03-13_09-31-32.png

Beim Share mit dem bischen Inhalt irritiert mich noch, daß er beim Anzeigen mit dem Dateibrowser vom NAS zwar angezeigt wird, aber eben nicht den vermuteten Inhalt hat, sondern den gesamten Dateibaum des NAS einschließt (zum Glück nicht rekursiv!):
Dateianhang:
Bildschirmfoto_2018-03-13_09-55-55.png

Kommt mir vor wie ein schlechter Traum! Wie kann es möglich werden, daß ich
  1. das verstehen kann;
  2. den ganzen entstandenen Kehricht wieder loswerden kann, ohne daß meine Daten in Gefahr geraten?
Das NAS ist zwar als RAID-1 konfiguriert und somit ziemlich sicher, aber wenn ich per Bedienungsfehler was lösche ist es natürlich auf beiden Platten weg; damit wäre 1 Jahr Arbeit vernichtet. :shock: Eine Drittsicherung anlegen kann ich leider nicht, weil ich keine 5 TB Speicher mehr frei habe.


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Mittwoch 14. März 2018, 10:14 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
ebbi97a hat geschrieben:
  • Diese unsichtbaren NFS-Shares scheinen also wirklich zu existieren und zwar ganz viele, wie man in der kleinen Liste auf der rechten Seite des Bildes sieht.
  • Was dem widerspricht sieht man ganz links oben: dort wird der vermeintliche NFS-Share mit smb: statt mit nfs: eingebunden.

Das habe ich nochmal verifiziert, indem ich mich per SSH als admin im ZyXEL-Betriebssystem angemeldet und umgeschaut habe. Der ganze von mir angelegte Müll ist da zu finden:
Dateianhang:
Bildschirmfoto_2018-03-13_13-36-32.png

Der Rahmen bleibt für mich unverständlich, aber das scheint wohl das Verzeichnis zu sein, wo die NFS-App aus der graphischen Konfigurationsoberfläche schalten und walten darf. Bemerkenswert ist, daß alle diese Verzeichnisse mit Ausnahme von nfs leer sind. Dieses Verzeichnis ist dasjenige von dem ich nicht weiß, wer es angelegt hat ― und es ist nicht leer! Dort befinden sich weitere Verzeichnisse:
Dateianhang:
Bildschirmfoto_2018-03-13_13-33-31.png

Sicherlich könnte ich jetzt dort löschen und den versehentlich erzeugten Kehricht loswerden ― aber ich traue mich nicht. Ich habe Höllenängste, meine ganze Arbeit zu vernichten. Es ist einfach alles zu undurchsichtig und die Zusammenhänge zwischen dem, was ich hier ganz real in der Shell sehe und dem, was die graphischen Oberflächen mir vorspiegeln, einfach nicht nachzuvollziehen sind.

Gerade hier wird es ganz schlimm:
  1. Wenn ich /NAS326/nfs im Dateimanager von Xubuntu öffne sind 4 Bilddateien drinnen. Das habe ich im vorangehenden Beitrag abgebildet.
  2. Wenn ich in der ZyXEL-Shell vom NAS suche finde ich nichts.
:hilfe:


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Mittwoch 14. März 2018, 23:53 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Vermutlich bin voll in die (__sonstwas__) getreten. Habe gerade folgendes (02.06.2016, 12:07) gelesen:
Zitat:
ich gehe davon aus, dass du in Windows über SMB auf das share gehst. Das erzeugte NFS Share ist jedoch ein neues Share, also nicht das bereits existierende SMB share, dass nun auch über das NFS Protokoll verfügbar gemacht wird, sondern ein egenständiges share. Du müsstest die Daten also doppelt ablegen (einmal im SMB-Share für Windows und einmal im NFS-Share für Linux) oder du verwendest einfach immer SMB (auch unter Linux). Funktioniert bei mir mit android und Kodi einwandfrei.

* samba und NFS Freigabe auf das selbe Share geht nicht.

Quelle: https://www.computerbase.de/forum/showthread.php?t=1589107&p=18864633#post18864633.

Dieser Verdacht nagte schon ein paar Tage auch an mir, aber das wollte ich nicht wahr haben, weil es mit meinem Archivserver (Debian) seit Jahren wunderbar klappt, mit NFS / Samba / FTP / AppleTalk usw. auf die gleichen Verzeichnisse zuzugreifen. Gibt es da eine Umgehung (z.B. Softlink)? Übrigens verwende ich nur NFSv4; NFSv3 habe ich nie verwendet, die 20 Jahre davor aber NFSv2.

Und selbst wenn das unumgänglich so wäre bleibt immer noch zu bemängeln, daß angelegt NFS-Shares nicht angezeigt werden. Meiner Meinung nach ist das ein echter Fehler und keine bedienungstechnische Besonderheit. Sollte ich vielleicht dem ZyXEL-Support (auf englisch?) melden.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Donnerstag 15. März 2018, 09:22 
Offline
engagiertes Mitglied

Registriert: Dienstag 22. Januar 2013, 12:49
Beiträge: 434
Eigentlich geht es. Es wurde hier im Forum z.B. beschrieben, wie man so einen Link umlenkt (symlink) oder man installiert via entware-ng einen eigenen NFS server und verzichtet auf den von Zyxel oder man installiert ein alternatives System (debian bzw. OMV 4)
viewtopic.php?f=207&t=11232
viewtopic.php?f=311&t=10515


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Donnerstag 15. März 2018, 12:22 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Vielen Dank! Der symlink wäre mir natürlich am sympathischsten. Die anderen beiden Vorschläge habe ich mir auch angeschaut, sie sind mir aber zu wartungsintensiv. Am liebsten wäre es mir, nahe an der von ZyXEL gepflegten Originalsoftware zu bleiben, weil das NAS keine andere Aufgabe haben wird, als zigtausende meiner Photos in den nächsten Jahren vorzuhalten und neue einzupflegen. Dabei soll jeder freigegebene Rechner im LAN komplikationsfrei Zugriff haben.

Jetzt aber zum Problem mit dem Symlink:
Zum Anlegen desselben braucht man das Kommando ln, die ZyXEL-Shell (so schreibe ich das mal in Ermangelung tieferer Einblicke in das Betriebssystem) ist kastriert und bietet dieses Kommando nicht an:
Dateianhang:
Bildschirmfoto_2018-03-15_11-04-27.png

Ein Verzeichnis mit Namen DIA habe ich schon; es enthält viele Unterordner und ist über FTP, AFP, SMB von anderen Rechnern bereits erreichbar. Allerdings liegt es nicht im Verzeichnis /home/shares und auch nicht in meiner Benutzerkennung, sondern in /i-data/8e3fd938/ :
Code:
/i-data $ cd /i-data/8e3fd938/; ls
DIA          aquota.user  music        photo
admin        lost+found   nfs          video
, wo auch nfs enthalten ist, welches wiederum die von NFS angelegten Shares enthält:
Code:
/i-data/8e3fd938 $ cd /i-data/8e3fd938/nfs; ls
DIAscan  v4Test
/i-data/8e3fd938/nfs $

Der Ordner DIAscan soll den Inhalt von DIA eine Ebene darüber und möglichst auch dessen Namen übernehmen. Noch sehe ich nicht, wie ich das hintricksen kann. Es scheint auch zu klappen, daß die anderen Protokollen auf Verzeichnisse unterhalb des Ordners nfs zugreifen können; mit FTP habe ich das schon getestet, mit AFP und SMB noch nicht.

Wäre es im Fall des Falles sinnvoll, DIA auf DIAscan verweisen zu lassen oder umgekehrt?


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Donnerstag 15. März 2018, 20:58 
Offline
engagiertes Mitglied

Registriert: Dienstag 22. Januar 2013, 12:49
Beiträge: 434
Dann nehme doch winscp, damit kannst du ohne probleme symlinks erstellen.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Dienstag 20. März 2018, 10:24 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Leider habe ich mit winscp auf Granit gebissen, aber vielleicht auch nur was übersehen:
  • Ich kriege mit dem NAS nur über FTP Verbindung.
  • SFTP und SCP funktionieren nicht, letzteres scheint dem Gerät nicht bekannt zu sein.
  • SSH bietet dagegen WinSCP nicht an.
  • Über FTP kann ich keine (symbolische) Verknüpfung anlegen.
Der Menüpunkt unter Dateien / Bearbeite Verknüpfung (Alt + F6) ist vermutlich dafür zuständig; der ist zwar lokal verfügbar, auf der FTP-Verbindung aber ausgegraut.
________________________________________

Nachtrag 19:03h

Jetzt habe ich es noch mit secpanel versucht, aber damit bekomme ich überhaupt keine Verbindung.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Dienstag 20. März 2018, 20:51 
Offline
engagiertes Mitglied

Registriert: Dienstag 22. Januar 2013, 12:49
Beiträge: 434
Aber ssh ist via webinterface aktiviert?


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Dienstag 20. März 2018, 21:54 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Auf dem NAS326 läuft der sshd; ich habe ihn ganz normal als Admin über die Weboberfläche eingerichtet und er ist über Terminal von verschiedenen Clients aus auch erreichbar. So habe ich ja ausgeforscht, wo das NAS die NFS-Verzeichnisse versteckt hat, die es über seine eigene Verwaltungsoberfläche einfach nicht anzeigen will.

Ich habe nur einen einzigen Windows-Client der obendrein in einem anderen Netzwerkzweig steht; vielleicht habe ich die Zugriffsrechte vermasselt. Mit secpanel von Linux aus im selben Netzwerkzweig (wie das NAS) komme ich aber auch nicht dran.
_____________________________________________

Nachtrag 2018-03-21_08:24 :
Der Fehler lag bei mir; ich hatte versucht, mich mit meiner normalen Benutzerkennung anzumelden, es geht aber nur mit der admin-Kennung.
Habe es gerade von einem Linux-System aus dem Netzwerkzweig, wo Windows installiert ist, mit dem ssh-Kommando versucht und das brachte Klarheit. Werde im Lauf des Tages deinen Ratschlag nochmals wiederholen.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an  Beitrag ist gelöst
BeitragVerfasst: Sonntag 1. April 2018, 20:53 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Jetzt habe ich aufgegeben weil ich festgestellt habe, daß "von Hand angelegte NFS-Shares" (damit meine ich solche Ordner, die z.B. per SSH oder SCP im entsprechen Teilbaum an der NFS-App vorbei angelegt worden sind) nicht gültig sind; sie sind per NFS nicht erreichbar.

Jetzt muß ich wohl schweren Herzens auf NFS verzichten und mir mit SMB behelfen, denn (bis jetzt) 5 TB will ich weder duplizieren noch in einen anderen Zweig verschieben wenn ich nicht vorher weiß, welche Pferdefüße da sonst noch lauern.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Montag 2. April 2018, 16:28 
Offline
engagiertes Mitglied

Registriert: Dienstag 22. Januar 2013, 12:49
Beiträge: 434
Vielleicht willst du dir das ja nochmal mit entware-ng überlegen. Ich war damals selber nicht mit der Originalen Zyxel NFS Software zufrieden und bin auf NFS via entware-ng umgestiegen.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Freitag 13. April 2018, 09:47 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Eigentlich wollte ich das NAS möglichst wartungsfrei betreiben -- also keine eigene Software dort installieren. Ist das entware-ng ein von ZyXEL unterstütztes Produkt oder muß ich mich da laufend selber drum kümmern?

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Freitag 13. April 2018, 16:27 
Offline
engagiertes Mitglied

Registriert: Dienstag 22. Januar 2013, 12:49
Beiträge: 434
Theoretisch selber drumm kümmern. Nur was wird von Zyxel noch aktualisiert? Eigentlich gar nichts mehr. Letzte Woche haben wir bei einem User z.B. Debian mit OMV auf sein 326 installiert.
Und das System hat auch eine schöne Gui und dürfte noch wartungsfreundlicher als das Zyxel System sein.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: NAS326 legt keine NFS-Shares an
BeitragVerfasst: Sonntag 15. April 2018, 16:19 
Offline
Mitglied

Registriert: Freitag 31. März 2017, 21:17
Beiträge: 14
Danke für den nochmaligen Hinweis! Habe mir jetzt die Informationen mal durchgelesen und so verstanden, daß das mitgekaufte Betriebssystem erhalten bleibt, aus einem zusätzlichen Repository allerdings damit kompatible Pakete (? "Apps") nachgeladen werden.

Habe auch über Open Media Vault nachgelesen. Das ist allerdings ein eigenständiges Betriebssystem, welches das mitgelieferte ersetzt. Macht einen guten Eindruck und die Installation würde ich mir auch zutrauen. Allerdings ist mir die Sache zu heiß: in monatelanger Arbeit habe ich mehr als 5 TB (rund 25000 Kleinbilddias) erfaßt und keinen Speicherplatz, um die extern zu sichern. Auf keinen Fall will ich die aber gefährden.

Jetzt gerade bin auch wieder daran, einige tausend Dias aus den Jahren um 1989 zu archivieren und bevor ich da nicht einen definierten Stand erreicht habe, werde ich keinen neuen Kriegsschauplatz eröffenen. Jedenfalls vielen Dank für die Aufklärung. Zunächst habe ich an meinem Verstand gezweifelt und konnte mir überhaupt nicht erklären, was das los ist. Ganz offensichtlich scheint es aber einen Fehler in der ZyXEL-Software zu geben, denn wenn eine Verwaltungsoberfläche Shares tatsächlich anlegt, in der Verwaltungsoberfläche aber so tut, als gäbe es keine, kann das wohl kaum richtig sein. Zusätzlich hat die ungewohnte Verwaltung der NFS-Shares in einem von den anderen Shares isolierten Pfad mich gehörig verwirrt.

_________________
NAS 326, 6 TB, RAID-1


Nach oben
 Profil  
 
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 16 Beiträge ]  Gehe zu Seite 1, 2  Nächste

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder: Google [Bot], Google Adsense [Bot]


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de


Impressum


Hubwagen  - Hubtisch  - Hochhubwagen  - günstige Hubwagen  - Hubwagen  - Hubtisch  - Scherenhubtische  - günstige Kehrmaschinen