Zyxel Deutschland Forum - Herzlich Willkommen!
http://www.zyxelforum.de/

NSA310S: Geschwindigkeit bricht nach einigen Tagen zusammen
http://www.zyxelforum.de/viewtopic.php?f=293&t=10944
Seite 1 von 2

Autor:  Everlast [ Dienstag 6. September 2016, 12:01 ]
Betreff des Beitrags:  NSA310S: Geschwindigkeit bricht nach einigen Tagen zusammen

Hallo,
ich habe ein NSA310S mit neuster Firmware. Verbaut ist eine WD Red 1TB Platte.

Das Problem: Wen neu gestartet, ist die Performance des NSA310S prima.
Doch nach einigen Tagen wird das Teil schnarchen langsam und kann erst durch einen Neustart wieder flott gemacht werden.

Bekanntes Problem??? :hilfe:

Ich habe nun erst mal über den Power Schedule einen wöchentlichen Reboot aufgesetzt, aber eine Behebung des Problems wäre mir lieber als diese Notlösung.

Gruß

Autor:  casati [ Mittwoch 7. September 2016, 01:37 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

TWEAKS installieren. Nicht benötigte Daemons ausschalten.

http://zyxel.nas-central.org/wiki/Category:NSA310s

Beste Grüße

Autor:  klomann [ Mittwoch 7. September 2016, 05:13 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Echt? Man muß erst 3rd Party-Kram installieren, damit ein Gerät ordnungsgemäß läuft?
Ist ja wie morgens gegen das Auto treten, damit es anspringt :wand:

Autor:  casati [ Mittwoch 7. September 2016, 09:42 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Es ist bei NAS Systemen - auch anderer Hersteller(!) - nicht unüblich, dass manche Anwendungssoftware (z.B. Twonky) das NAS System dauerhaft beschäftigt.

Wir können froh sein, dass unser niederländischer "Mitstreiter" Mijzelf so viel seiner Zeit investiert hat, um diese nützlichen Hilfsmittel zu entwickeln bzw. zusammenzustellen.

Beste Grüße

Autor:  Everlast [ Mittwoch 7. September 2016, 12:30 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

casati hat geschrieben:
Es ist bei NAS Systemen - auch anderer Hersteller(!) - nicht unüblich, dass manche Anwendungssoftware (z.B. Twonky) das NAS System dauerhaft beschäftigt.

Wir können froh sein, dass unser niederländischer "Mitstreiter" Mijzelf so viel seiner Zeit investiert hat, um diese nützlichen Hilfsmittel zu entwickeln bzw. zusammenzustellen.

Beste Grüße


Danke. Ich habe Twonky nun mal im Admin Menue deaktiviert. Mal sehen, vielleicht hilft das ja schon was ... bevor ich zu schwereren Geschützen greife (Tweaks).

Sollte das NAS nochmals lahmen, werde ich mir den Status mal anschauen (ob das Memory vollgelaufen ist). Kam leider bisher nicht auf die Idee.

Autor:  Everlast [ Sonntag 11. September 2016, 15:08 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Es ist mal wieder soweit. Das NAS antwortet sehr langsam.

Der Status zeigt: CPU Usage 100%.

Top 3 sind:

No. 1 smbd 96.2%
No. 2 zyshd 2.9%
No. 3 ksoftirqd/0 0.0%

Warum nudelt der smbd mit 96% CPU?

Gruß Jo

Autor:  Mijzelf [ Sonntag 11. September 2016, 15:34 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

As this is AFAIK not a know problem with the 310S, I guess there is something else in your network effectively doing a DOS attack on Samba.

With some luck that box is having one or more open connections with Samba, which means you can pinpoint it by looking at the network connections:
Code:
netstat -tp
If you don't have shell access, you can also use the 'Network Info' in Tweaks.

Autor:  Everlast [ Montag 12. September 2016, 09:56 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Thank you. No, I got neither shell access nor Tweaks so far, but consider installing Tweaks on the next occasion.

I got two WiFi cams (Edimax and Hootoo) that do frequent FTP logins/logouts to upload motion detection triggered pictures.

Could that be the reason? Does FTP engage Samba somehow?

Autor:  Mijzelf [ Montag 12. September 2016, 11:08 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Frequent ftp logins. Hmm.

Every login (except shell login) is somehow handled by Samba login, as the passwords are only stored in Samba format. But I don't know how it's implemented, if smbd has anything to do with it, or if it's only some shared library.

You can try if using anonymous ftp access solves that problem. I guess that camera's are inside your lan? Else it's a bad idea, of course.

Autor:  Everlast [ Freitag 30. Dezember 2016, 15:02 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Hello again,

I succeeded now to install Tweaks. CPU is again at 100%.
Network Infos says:

Code:
Active connections
Local   Remote   Daemon
127.0.0.1:445   127.0.0.1:4702   17893/smbd
127.0.0.1:4691   127.0.0.1:445   2456/nsuagent
127.0.0.1:445   127.0.0.1:4695   17886/smbd
127.0.0.1:4700   127.0.0.1:445   2456/nsuagent
127.0.0.1:4698   127.0.0.1:445   2456/nsuagent
127.0.0.1:4693   127.0.0.1:445   2456/nsuagent
127.0.0.1:445   127.0.0.1:4694   17885/smbd
127.0.0.1:445   127.0.0.1:4692   17883/smbd
127.0.0.1:4695   127.0.0.1:445   2456/nsuagent
127.0.0.1:445   127.0.0.1:4700   17891/smbd
192.168.178.15:445   192.168.178.21:65069   14668/smbd
127.0.0.1:445   127.0.0.1:4699   17890/smbd
127.0.0.1:4694   127.0.0.1:445   2456/nsuagent
192.168.178.15:80   192.168.178.21:49351   17950/httpd
127.0.0.1:445   127.0.0.1:4698   17889/smbd
127.0.0.1:4699   127.0.0.1:445   2456/nsuagent
127.0.0.1:445   127.0.0.1:4701   17892/smbd
127.0.0.1:445   127.0.0.1:4691   17882/smbd
127.0.0.1:4692   127.0.0.1:445   2456/nsuagent
127.0.0.1:4701   127.0.0.1:445   2456/nsuagent
127.0.0.1:4702   127.0.0.1:445   2456/nsuagent
127.0.0.1:445   127.0.0.1:4693   17884/smbd


I'm not very familiar with these network things. Do you see anything suspicious?

Bild

How to proceed to find and kill the problem?

Autor:  Mijzelf [ Montag 2. Januar 2017, 17:33 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Samba seems to be mainly talking to itself. The only connection 'from outside' is from 192.168.178.21, which is your PC, I guess.

Which OS is that PC using? In the past there were some problems with Linux clients.

Autor:  Everlast [ Montag 9. Januar 2017, 14:59 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Thanks for your answer.

Yes, 192.168.178.21 is my PC. It is running Windows 10, latest Build.

Righ now the CPU is again at 100% and it takes several seconds to open a 1MB jpg file.

smbd eats 97,1%, zyshd 2,9%.

I'm inclined to throw the drive out of the windows. :-(

Autor:  Mijzelf [ Montag 9. Januar 2017, 21:02 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Long shot. Is it possible that Windows is indexing the shares, or doing a virusscan, or something like that?

Autor:  ombre33 [ Dienstag 10. Januar 2017, 09:30 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Habe ein ähnliches Problem:

Ein DVR-Gerät im Netzwerk (Technisat TechniCorder ISIO STC, BS ist soweit ich weiß irgend so ein geforktes Linux (?)) speichert seine Aufnahmen direkt auf eine NAS540. Ab und zu (z.B. bei Übertragungen von Aufzeichnungen von der internen Festplatte des DVRs auf das NAS oder bei der Übertragung der SFI-Dateien) scheint sich der Samba-Prozess „aufzuhängen“. In meinem Fall nicht ganz so schlimm, da der Prozess nur eine der beiden CPUs voll auslastet. Lasse ich den aufgehängten Samba-Prozess aber für ein paar Stunden rödeln, startet sich die NAS irgendwann von selbst neu. Ist ein Neustart nicht gewünscht, ist kill -9 die Waffe der Wahl.

Für Ursachenforschung bzw. –einstellung habe ich weder die Kenntnisse noch die Zeit.

Meine Annahme ist, dass die Ursache einer deiner beiden Kameras ist (k.A. wie wahrscheinlich, da Übertragung via FTP) oder ein anderes Netzwerkgerät, dass per samba Daten auf die NAS schiebt.

Autor:  Everlast [ Mittwoch 11. Januar 2017, 19:11 ]
Betreff des Beitrags:  Re: NSA310S: Geschwindigkeit bricht nach einigen Tagen zusam

Mijzelf hat geschrieben:
Long shot. Is it possible that Windows is indexing the shares, or doing a virusscan, or something like that?


Thanks for the idea, but the network drives neither appear in Windows Defender options nor in the Windows indexing options.

I now set up daily restarts of the drive to get rid of any zombies. It's a crook, but I guess I have to live with it.
Nevertheless I will try to detach the two Chinese cams for a few days and see if that makes any difference.

Seite 1 von 2 Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/