Zyxel Deutschland Forum - Herzlich Willkommen!

Für Support Anfragen nutzen Sie http://support.zyxel.eu oder als Fachhändler http://partner.zyxel.eu
Aktuelle Zeit: Sonntag 24. Juni 2018, 03:42

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]



 


Ein neues Thema erstellen Auf das Thema antworten  [ 19 Beiträge ]  Gehe zu Seite Vorherige  1, 2
Autor Nachricht
 Betreff des Beitrags: Re: FW 4.31 ist released - Fehler und Bugs?
BeitragVerfasst: Donnerstag 17. Mai 2018, 22:50 
Offline
Experte

Registriert: Dienstag 6. Mai 2008, 00:30
Beiträge: 967
nils50122 hat geschrieben:
Die V4.31 ist eine mittelschwere Katastrophe.

Nach dem Update der passiven USG110 wird dann automatisch die aktive USG110 im HA-Pro Cluster geupdatet und neugestartet.
Ende vom Lied -> die aktive USG ist nicht mehr hochgefahren, also auch nicht mehr über die MGM-IP erreichbar und hätte im "Ernstfall" den Dienst der anderen USG nicht übernommen.

Lösung: Totalreset, Downgrade auf V4.30WK13, Auflösung des HA-Pro-Clusters, Einspielen eines Backups von V4.30 und Neukonfiguration des HA-Pro-Clusters.
Da kommt Freude auf, Man(n) hat ja sonst nichts zu tun.

Hmmm, ärgerlich! Aber mal abgesehen davon, dass Du Dir bei der Problemlösung das Leben selbst nur unnötig schwer gemacht hast, sofern Du wirklich beide Boxen wieder downgegraded hast (Du hattest doch danach einen laufenden Node mit 4.31 oder?), kann ich ein generelles Upgradeproblem nicht bestätigen. Ich habe kürzlich sowohl einen USG310- als auch einen VPN100-HApro-Cluster jeweils von 4.30(Patch0/GA) auf 4.31 upgedatet. Völlig ohne Probleme.
Eines der vorgenannten Systeme werkelt in einer Feuer- und Rettungswache. Die arbeiten natürlich 24/7 - sprich: das musste im laufenden Betrieb gemacht werden. Dort gehen permanent Schnittstellendaten zwischen dem Einsatzleitsystem und Digitalfunk/Digitale Alarmierung/Telefonanlage/Gebäudesteuerung usw. über die Firewall. Einige dieser Schnittstellen liefern bei einer Verbindungsunterbrechung sofort eine Fehlermeldung an den Disponenten. Eine dieser Schnittstellen muss danach sogar wieder händisch aktiviert werden. Nichts von alledem ist während des Updates passiert. Er hat automatisch nacheinander beide Boxen aktualisiert und dabei die bestehenden Sessions sauber zwischen den Nodes übergeben. Da ist nichts abgebrochen.
Wie bist Du denn zur Aktualierung vorgegangen? Hast Du vielleicht nach der Vorgehensweise für das "klassische" Device-HA gearbeitet, wonach man - mit der Backup-Unit beginnend - beide Nodes händisch aktualisiert? Das ist bei HA-Pro nicht mehr erforderlich. Jedenfalls nicht bei einem Update über die Cloud. Einfach auf der virtuellen IP des Clusters anmelden, Cloudupdate anstoßen und den Rest erledigt die HApro-Logik ganz von alleine. Bei 4.20 oder 4.25 war da noch ein kleiner Fehler drin, aber bei 4.30 auf 4.31 hat das gut funktioniert.


nils50122 hat geschrieben:
Mir kommt es so vor als würde ZyXEL in den letzten Firmwarereleases sehr viel rumspielen und alte Fehler wieder einbauen.
Vor zwei Monaten hatten wir bereits eine Buggy-Firmware die TCP-Sessions nach einer gewissen Zeit trennt.
Ah ok. Also ist der Bug, dass der TCP-Esteblished-Timer seit 4.30P0/GA offenkundig ein "hartes" Timeout ist, bereits bekannt und in einer WK-Firmware zu 4.30 schon gefixt gewesen? Ich wollte gerade einen Case aufmachen...
Hab mir hier einen Wolf nach der Ursache gesucht. Drauf gebracht hat mich die obige Feuerwehr, wo man in den Logs die 2,5h des Defaultwertes obigen Timers herauslesen konnte. Bei den diversen Rückmeldungen der "normalen" Anwender der anderen Systeme konnte ich zunächst keine Regelmäßigkeiten entdecken, weil die Sessions zu unterschiedlichen Zeiten starten.

Dass eine neue - generell verfügbare - Firmwareversion nicht alle Patche beinhaltet, die bereits in WK-Versionen zur Vorversion enthalten waren, ist bei Zyxel (und nicht nur dort) leider völlig normal und in gewissen Grenzen auch verständlich (z.B. erforderliche Betatestphase bis zur Aufnahme ins Stable noch nicht abgeschlossen oder zeitliche Überschneidung zwischen Verfügbarkeit des Patches und "Freeze" des Codes für die Stable). Bei dem vorgenannten Problem bin ich darüber aber auch verärgert. Das ist so klar reproduzierbar und von so grundlegender Bedeutung und Tragweite, dass die Aufnahme des Patches in eine GA-Version möglichst kurz sein muss. Mehr als 2 Monate nach Verfügbarkeit eines Patches beim Support hätte dieser m.E. längst für die Allgemeinheit verfügbar sein müssen. Wenn ich da jetzt einen Case zu aufmache, wollen die mir bestimmt ein Downgrade auf die WK zu 4.30 andrehen... :roll:


Gruß
sk

_________________
Verkaufe aufgrund planmäßiger Erneuerung diverse gebrauchte WLAN-Accespoints vorwiegend vom Typ NWA5560-N sowie ggf. weitere Business-Netzwerkkomponenten von ZyXEL (WLAN-Controller, Switches, Firewalls usw.). Bei Interesse bitte eine PN an mich.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: FW 4.31 ist released - Fehler und Bugs?
BeitragVerfasst: Dienstag 29. Mai 2018, 08:26 
Offline
interessiertes Mitglied
Benutzeravatar

Registriert: Freitag 13. Dezember 2013, 11:31
Beiträge: 180
Moin,

auch mal kurze Rückmeldung von mir bzgl. des fehlenden Daily Log Reports. Der Support hat mir vor ein paar Tagen eine v4.30 WK17 zur Verfügung gestellt. Gestern abend habe ich es nun endlich geschafft, diese einzuspielen. Update lief über die Browser GUI ohne Probleme. Danach ein Neustart und fertig. ... Und siehe da, heute Nacht wurde zum ersten mal wieder ein Daily Log Report verschickt. :fg:
Jetzt ist natürlich wieder die große Frage, was mache ich mit der v4.31? Zumindest habe ich erstmal angefragt, ob das Problem auch in der 4.31 auftreten kann. Erst mal bleiben wir jetzt auf der 4.30.

Jörg


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: FW 4.31 ist released - Fehler und Bugs?
BeitragVerfasst: Dienstag 29. Mai 2018, 19:54 
Offline
engagiertes Mitglied
Benutzeravatar

Registriert: Dienstag 25. Juni 2013, 20:01
Beiträge: 429
Moin Jörg,
auch bei mir gibt es Neuigkeiten bzw. der FW 4.31 und dem Hänger, wenn die USG rebootet wird :denk:
Ich habe eine Debug-Version der FW bekommen, die (warum auch immer) den reboot sauber ausführt.
Wenn ich dann wieder auf die FW 4.31 release hochziehe, dann ist der Fehler wieder da :shock:
Der Kollege in TW ist langsam ratlos, aber die debug-edition kann man nicht ohne das debug als WK version bereitstellen :cry:

Ich bin daher gespannt, was noch raus kommt :fg:

Gruss
Christian


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: FW 4.31 ist released - Fehler und Bugs?
BeitragVerfasst: Samstag 2. Juni 2018, 20:04 
Offline
engagiertes Mitglied
Benutzeravatar

Registriert: Dienstag 25. Juni 2013, 20:01
Beiträge: 429
Hallo zusammen,
langsam wird es bei mir ein mysterium, das jetzt zwar gelöst ist, aber dennoch viele Fragezeichen aufwirft :traurig:

1. Debug-FW wurde ohne probleme auf die USG gespielt, installiert und hat auch sauber rebootet.
2. wenn man dann wieder die FW 4.31 installiert hat - ist der fehler wieder zurück gekommen :shock:
3. Debug-FW wieder drauf - und die USG lief wieder sauber.

Jetzt die neueste Erfahrung mit der 4.3x Firmware :shock:
1. Erneut die FW 4.31 installiert (startete natürlich nicht automatisch durch) :wand:
2. debug level per SSH erhöht und die USG erneut rebootet - und siehe da, die USG startet mit einer 4.3x Firmware durch :shock:

Ich habe die USG heute 4x (3x per SSH ud 1x per GUI) rebootet und sie blieb nicht hängen .... :denk: was auch immer da falsch gelaufen ist :roll:

Gruss
Christian


Nach oben
 Profil  
 
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 19 Beiträge ]  Gehe zu Seite Vorherige  1, 2

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder: Google [Bot]


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de


Impressum


Hubwagen  - Hubtisch  - Hochhubwagen  - günstige Hubwagen  - Hubwagen  - Hubtisch  - Scherenhubtische  - günstige Kehrmaschinen