Zyxel Deutschland Forum - Herzlich Willkommen!

Für Support Anfragen nutzen Sie http://support.zyxel.eu oder als Fachhändler http://partner.zyxel.eu
Aktuelle Zeit: Dienstag 23. Oktober 2018, 11:52

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]



 

Forumsregeln


Achtung: FFP ist eine Zusatzanwendung, für die ZyXEL keinen Support übernimmt!
Sämtliche Support Anfragen zu FFP Produkten werden nicht bearbeitet.
Bei Fragen zu FFP wenden Sie sich am besten in Englisch an unser Forum oder an http://forum.nas-central.org/viewforum.php?f=21



Ein neues Thema erstellen Auf das Thema antworten  [ 126 Beiträge ]  Gehe zu Seite Vorherige  1 ... 4, 5, 6, 7, 8, 9  Nächste
Autor Nachricht
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Freitag 14. September 2018, 20:29 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
Deacon hat geschrieben:
@ElektromAn

Hier ist aber die 3. und 4. Platte missing. Daher keine Daten...Da sollte eigentlich nur die 4. auf missing stehen. sdc3 steht auch auf F

h0tic3 hat geschrieben:
Code:
~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sda3[0] sdc3[2](F) sdb3[1]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/2] [UU__]


Habe ich gar nicht gesehen ...
F -> FAULTY
meistens durch
Code:
mdmadm --fail

muss aber nicht sein

@h0tic3
Wolltest du die Daten per USB3 "überspielen" ??
also SATA->USB3 ??

mir geht (langsam) ein Teil der Firmware auf den *Keks*
ich bin dran einige Dienste abzuschalten.

Muss mir nochmal (*) das Update Script ansehen.
Da werden auch einige Sachen beendet ...

(*)
Brauchte ich mal, da hier einer aus dem Forum
sich seinen Bootloader und/oder Firmwarepartitionen auf
dem Flash zerschossen hatte.
Die Kiste hatte ich mal auf dem Seziertisch ...
So nebenbei das mit dem Flash war nicht sein Fehler ...





dann sollte auch
mount einen Fehler zeigen, was aber bei älteren Kernels glaube ich Fehlerhaft war.

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Samstag 15. September 2018, 01:07 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Ja, ich wollte die Daten per USB3 überspielen. Habe es per PC versucht. Aber da die Daten ja nicht vorhanden sind, oder nur teilweise wenn ich Glück habe, hat es nicht geklappt.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Samstag 15. September 2018, 14:31 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
h0tic3 hat geschrieben:
Ja, ich wollte die Daten per USB3 überspielen. Habe es per PC versucht. Aber da die Daten ja nicht vorhanden sind, oder nur teilweise wenn ich Glück habe, hat es nicht geklappt.

OK.

Wenn du das auch beim "ersten" Mal versucht hast haben war vielleicht auch den Grund für den plötzlichen Reset.
... keine Angst ist *nicht* dein Fehler gewesen.
Er sollte gar *nicht* erst auftreten !

So nun schau ich mir mal die Sache auf dem NAS an.
Dauer bis heute abend, ich habe meine Hardware im Netz
anders angeordnet und kann kein WOL auf das NAS machen.
Und ohne WOL nutzt mir die serielle Console nichts.

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Samstag 15. September 2018, 15:04 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Ich danke dir so sehr das du dir so viel Mühe machst mir zu helfen. Ohne dieses Forum und euch alle hier wäre ich komplett aufgeschmissen. Ich danke euch allen.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 16. September 2018, 13:47 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
So ich werfe erstmal einige Links ab ...
Und ein wenig Erklärung was ich vorhabe ...
z.B. für Mijzelf oder deacon

Ubuntu page über LVM
https://wiki.ubuntuusers.de/Logical_Volume_Manager/
Ist für (fast) alle Linuxe gleich.

EDIT:
Noch eine gute Seite bei Thomas Krenn
https://www.thomas-krenn.com/de/wiki/LVM_Grundkonfiguration

Beschreibung von mdev
https://git.busybox.net/busybox/tree/docs/mdev.txt
das ist ähnlich wie udev (oder systemd) auf Desktop Boxen
Das Läuft auf dem NAS als Hotplug "Agent" im Hintergrund

Wichtig sind hier
Code:
The special characters have the meaning:
   @ Run after creating the device.
   $ Run before removing the device.
   * Run both after creating and before removing the device.

Dazu noch ein Ausschnitt aus /etc/mdev.conf auf dem NAS
Code:
/ # grep -n .  /etc/mdev.conf
30:$DEVTYPE=disk           root:root       660     */sbin/hotplug
31:$SUBSYSTEM=usb[a-z]*    root:root       660     */sbin/hotplug

Der Trick mit dem "grep" ist, weil auf der BOX "cat" mir keine Zeilennummer ausgibt.

Die Zeilen 30 und 31 sind dafür zuständig, weiter Helper in
Code:
/ # ls /usr/sbin/hotplug_*
/usr/sbin/hotplug_add_SATA.sh        /usr/sbin/hotplug_remove_SATA.sh
/usr/sbin/hotplug_add_storage.sh     /usr/sbin/hotplug_remove_storage.sh
/ #

aufzurufen.
Die Namen dürften eindeutig sein ;-)
SATA intern, storage dürfte extern sein.

Die komplette LVM Verwaltung von Zyxel habe ich noch nicht gefunden,
dürfte aber egal sein, s.o.

Mein Plan ist erst nur die Zyxel-Helper auszuschalten und danach den mdadm daemon.
Der Rest dürfte mir keine Probleme machen.
Das folgt alles heute noch.

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 16. September 2018, 15:00 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
So Vorbereitungen ...
mdadm Überwachung aus
Code:
kill $(pgrep mdadm)

Zyxel Hotplug addons aus
Code:
sed "/hotplug/d" -i /etc/mdev.conf
echo > /proc/sys/kernel/hotplug
echo /sbin/mdev > /proc/sys/kernel/hotplug


LVM unmounten und aus
Code:
umount /i-data/6093c7bb
umount /mnt/vg_info_area/vg_ead2a518
vgchange -a n


RAID5 aus
Code:
mdadm --stop /dev/md2


So wenn du willst kannst du deinen USB3->SATA Adpter mit Festplatte anklemmen.
gemounted wird das Laufwerk jetzt nicht, da die Zyxel Dienste dafür aus sind.

Du siehst nur die "fünfte" Platte aka /dev/sde in
Code:
cat /proc/partitions

Mach auch biite mal ein
Code:
mount

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 16. September 2018, 15:16 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Leider bekomme ich beim ersten unmount bereits einen Fehler:

Code:
~ # umount /i-data/6093c7bb
umount: /i-data/6093c7bb: target is busy
        (In some cases useful info about processes that
         use the device is found by lsof(8) or fuser(1).)
~ #


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 16. September 2018, 21:27 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
Ja, Ja, Ja ...
Hintergrundprocezze vergessen zu "killen"

Da ich jetzt zu faul bin dir *alle* möglichen Prozesse anzugeben,
und ich auch nicht weiss ob du noch die "Apps" am laufen hast
machen wir es professionell ..

Code:
for p in $(lsof -n | grep 6093c7b | awk '{ print $2}' | sort | uniq); do
   kill $p; sleep 1; kill -9 $p;
done


Per COpy und Paste eingeben

Ich suche da die Programme mit den offenen Files durch "lsof" die einen Teilpfad
hier "6093c7b" drin habe (deine Datenpartition), schneide die Prozessnummern aus.
Sortiere und hole nur die "unikate" heraus.
Ich muss sortieren, da wegen effizienz die Ausgabe von "lsof" nicht sauber ist
und "uniq" dann nur wirres Zeug ausgibt
Im Prinzip ist das bei dem Befehl "find" usw. auch ...

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 17. September 2018, 01:02 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
OK, danke dir.

Da bin ich jetzt:
Code:
BusyBox v1.19.4 (2018-05-22 01:23:15 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # for p in $(lsof -n | grep 6093c7bb | awk '{ print $2}' | sort | uniq); do
>    kill $p; sleep 1; kill -9 $p;
> done
sh: can't kill pid 24255: No such process
~ # umount /i-data/6093c7bb
~ # umount /mnt/vg_info_area/vg_ead2a518
umount: /mnt/vg_info_area/vg_ead2a518: not mounted
~ # umount /i-data/6093c7bb
umount: /i-data/6093c7bb: not mounted
~ # vgchange -a n
  0 logical volume(s) in volume group "vg_ead2a518" now active
~ # mdadm --stop /dev/md2
mdadm: stopped /dev/md2
~ # cat /proc/partitions
major minor  #blocks  name

   7        0     147456 loop0
  31        0        256 mtdblock0
  31        1        512 mtdblock1
  31        2        256 mtdblock2
  31        3      10240 mtdblock3
  31        4      10240 mtdblock4
  31        5     112640 mtdblock5
  31        6      10240 mtdblock6
  31        7     112640 mtdblock7
  31        8       6144 mtdblock8
   8        0 5860522584 sda
   8        1    1998848 sda1
   8        2    1999872 sda2
   8        3 5856522240 sda3
   8       16 5860522584 sdb
   8       17    1998848 sdb1
   8       18    1999872 sdb2
   8       19 5856522240 sdb3
   8       32 5860522584 sdc
   8       33    1998848 sdc1
   8       34    1999872 sdc2
   8       35 5856522240 sdc3
   8       48 5860522584 sdd
   8       49    1998848 sdd1
   8       50    1999872 sdd2
   8       51 5856522240 sdd3
  31        9     102424 mtdblock9
   9        0    1997760 md0
   9        1    1998784 md1
  31       10       4464 mtdblock10
   8       64 4883770583 sde
   8       65     131072 sde1
   8       66 4883638272 sde2
~ # mount
/proc on /proc type proc (rw)
/sys on /sys type sysfs (rw)
none on /proc/bus/usb type usbfs (rw)
devpts on /dev/pts type devpts (rw)
ubi5:ubi_rootfs1 on /firmware/mnt/nand type ubifs (ro)
/dev/md0 on /firmware/mnt/sysdisk type ext4 (ro)
/firmware/mnt/sysdisk/sysdisk.img on /ram_bin type ext2 (ro)
/ram_bin/usr on /usr type none (ro,bind)
/ram_bin/lib/security on /lib/security type none (ro,bind)
/ram_bin/lib/modules on /lib/modules type none (ro,bind)
/ram_bin/lib/locale on /lib/locale type none (ro,bind)
/dev/ram0 on /tmp/tmpfs type tmpfs (rw,size=5m)
/tmp/tmpfs/usr_etc on /usr/local/etc type none (rw,bind)
ubi3:ubi_config on /etc/zyxel type ubifs (rw)
configfs on /sys/kernel/config type configfs (rw)
~ #


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 17. September 2018, 14:56 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
So alles ist soweit I.O.

dann mal das RAID5 wieder zusammenbauen
Code:
mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 --metadata=1.2 --chunk=64K --layout=left-symmetric /dev/sd[a-c]3 missing --force

Das taucht auch wieder unter
Code:
cat /proc/mdstat

auf.

Verzeichnisse erzeugen fürs Backup
Code:
mkdir /mnt/raid5
mkdir /mnt/ntfs

Beim ersten könnte ein Fehler kommen, weil schon vorhanden, das zweite ist für die externe Platte

Ich mache (wie gehabt) erstmal die harte Tour über loop Device
Code:
losetup -o $((64*1024)) /dev/loop1 /dev/md2


Dann
Code:
mount /dev/loop1 /mnt/raid5 -r

Ein
Code:
ls /mnt/raid5 -lR

sollte jetzt (fast) ohne Fehler laufen.

Ich bin auch schon am Überlegen, wie die Daten kopiert werden können ...
Das Problem ist ja, wenn Fehler auf dem Filesystem sind, dann brechen die meisten Tools ab.
(hoffentlich ist/sind die Verzeichnisse OK)

Und wenn es geht, möchte ich in verschiedenen Versionen "kopieren"
um einen maximalen erfolg zu haben.
... ob und wieviel davon *Müll* ist muss du leider entscheiden ;-)

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 17. September 2018, 23:24 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Danke dir für die ganzen Commands.

Leider ist es genau wie vorher. Sprich ich komme auf die Ordner, diese sind aber leer. In einigen ist was drin, was allerdings nicht geöffnet oder kopiert werden kann.

Noch ein kurzer Auszug aus der BusyBox:
Code:
BusyBox v1.19.4 (2018-05-22 01:23:15 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # buzzerc -s && mv /sbin/buzzerc /sbin/buzzerc.old
~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sdb3[0] sdd3[2](F) sdc3[1]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/2] [UU__]

md1 : active raid1 sdd2[6] sdc2[5] sdb2[4] sde2[7]
      1998784 blocks super 1.2 [4/4] [UUUU]

md0 : active raid1 sdd1[6] sdc1[5] sdb1[4] sde1[7]
      1997760 blocks super 1.2 [4/4] [UUUU]

unused devices: <none>
~ # ls /mnt/raid5 -lR
ls: /mnt/raid5: No such file or directory
~ # mount /dev/loop1 /mnt/raid5 -r
mount: mount point /mnt/raid5 does not exist
~ #


Ich bin leider noch immer ratlos. :(


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 18. September 2018, 09:14 
Offline
Open Source Hero

Registriert: Dienstag 24. Juni 2008, 10:33
Beiträge: 2282
h0tic3 hat geschrieben:
Code:
~ # ls /mnt/raid5 -lR
ls: /mnt/raid5: No such file or directory
~ # mount /dev/loop1 /mnt/raid5 -r
mount: mount point /mnt/raid5 does not exist
~ #

You forgot
ElektromAn hat geschrieben:
Code:
mkdir /mnt/raid5
mkdir /mnt/ntfs


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 18. September 2018, 10:53 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
I already did this before. But I did it again... ;)


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 18. September 2018, 19:56 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
h0tic3 hat geschrieben:
Danke dir für die ganzen Commands.

Leider ist es genau wie vorher. Sprich ich komme auf die Ordner, diese sind aber leer. In einigen ist was drin, was allerdings nicht geöffnet oder kopiert werden kann.

Noch ein kurzer Auszug aus der BusyBox:
Code:
BusyBox v1.19.4 (2018-05-22 01:23:15 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # buzzerc -s && mv /sbin/buzzerc /sbin/buzzerc.old
~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sdb3[0] sdd3[2](F) sdc3[1]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/2] [UU__]


Ich bin leider noch immer ratlos. :(

... Wenn man(n)den Fehler einmal gesehen hat

Warum wird /dev/sdd3 "eingebunden" ??
Und natürlich nacher "gekicked" (*)

mach mal bitte ein
Code:
dmesg | tail -n 150


(*)
interessant,
wenn ich micht richtig erinnere wird immer eine *neue* RAID UUID erzeugt
Mmm,
noch seltsamer
sdb3[0] sdd3[2](F) sdc3[1]
sind im ARRAY ...
sollte aber
sda, sdb, sdc
sein.

Nochmal Hmmm,
vielleicht sollte ich die "vierte" Platte aus dem System nehmen
.. damit das nicht passiert.

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 18. September 2018, 23:32 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Werde ich morgen mal machen. Aber da morgen früh der Strom abgestellt wird werde ich das NAS erstmal ausschalten.


Nach oben
 Profil  
 
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 126 Beiträge ]  Gehe zu Seite Vorherige  1 ... 4, 5, 6, 7, 8, 9  Nächste

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder: Exabot [Bot], Google [Bot], Google Adsense [Bot]


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de


Impressum


Hubwagen  - Hubtisch  - Hochhubwagen  - günstige Hubwagen  - Hubwagen  - Hubtisch  - Scherenhubtische  - günstige Kehrmaschinen