Zyxel Deutschland Forum - Herzlich Willkommen!

Für Support Anfragen nutzen Sie http://support.zyxel.eu oder als Fachhändler http://partner.zyxel.eu
Aktuelle Zeit: Dienstag 23. Oktober 2018, 22:21

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]



 

Forumsregeln


Achtung: FFP ist eine Zusatzanwendung, für die ZyXEL keinen Support übernimmt!
Sämtliche Support Anfragen zu FFP Produkten werden nicht bearbeitet.
Bei Fragen zu FFP wenden Sie sich am besten in Englisch an unser Forum oder an http://forum.nas-central.org/viewforum.php?f=21



Ein neues Thema erstellen Auf das Thema antworten  [ 126 Beiträge ]  Gehe zu Seite Vorherige  1, 2, 3, 4, 5 ... 9  Nächste
Autor Nachricht
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 6. August 2018, 09:19 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
No, I didn't rebooted the NAS in between all the commands. Or do you mean after the volume went down?


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 6. August 2018, 19:10 
Offline
Open Source Hero

Registriert: Dienstag 24. Juni 2008, 10:33
Beiträge: 2282
No, I meant between 2 'mdadm --stop' actions.

Initially you couldn't stop the array due to a 'not existing file or directory'. You created the /dev/md2 devicenode with mknod, and then the array stopped. Later the error 'not existing file or directory' returned, while /proc/mdstat still shows the array.

Wait, scratch that. In your latest log the array is in /dev/md3. So apparently something is re-assembling in the background, and as /dev/md2 was in use (maybe by the monitoring mdadm), the system used the next multidisk device.
So maybe you need to be fast, after stopping the array.
Code:
killall mdadm
mknod /dev/md3 b 9 3
mdadm --stop /dev/md3 && mdadm --create ...
Here /dev/md3 will be stopped, and in case that device node doesn't exist we create it.
The '&& mdadm --create' means that the command will be execute directly when the mdadm --stop succeeds. (If it doesn't succeed the create won't be executed)


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 6. August 2018, 22:10 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
OK, so what do I need to do right now? Sorry, I'm not fit in Linux at all. So I just need to type in the commands in a rush and then there should be something that my NAS is doing?


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 7. August 2018, 09:53 
Offline
Open Source Hero

Registriert: Dienstag 24. Juni 2008, 10:33
Beiträge: 2282
h0tic3 hat geschrieben:
So I just need to type in the commands in a rush
No, no. By putting the 2 mdadm commands on a single line with an && in between, the commands are executed as soon as possible after each other.
No need to type fast, fortunately, as that is only begging for typo's.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 7. August 2018, 10:34 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Thanks for the explanation. But I'm still confused. ;)

After the first two lines I got this:
BusyBox v1.19.4 (2018-05-22 01:23:15 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # killall mdadm
killall: mdadm: no process killed
~ # mknod /dev/md3 b 9 3
mknod: /dev/md3: File exists
~ #

Is that the correct way? So now I just need to enter the third line?


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 7. August 2018, 11:20 
Offline
Open Source Hero

Registriert: Dienstag 24. Juni 2008, 10:33
Beiträge: 2282
Yes, that is the correct way. Both commands are 'just in case'. The mdadm daemon should not be running, as you already killed it. But if you rebooted the box, or if some firmware daemon restarted it <omitted the rest of the line>

And /dev/md3 should also exist, and so should /dev/md2, but the latter didn't.

So this is not surprising behaviour.

You can go ahead.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 7. August 2018, 12:00 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Awesome. So this could really work?

So what do I need to enter in the command line right now? I don't think that the command line with the ... is complete, correct? Or is it the correct command?


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 7. August 2018, 12:30 
Offline
Open Source Hero

Registriert: Dienstag 24. Juni 2008, 10:33
Beiträge: 2282
h0tic3 hat geschrieben:
So this could really work?
That is the expected behaviour.
Zitat:
I don't think that the command line with the ... is complete, correct?
No, the ... stands for the whole blurp which has to be added after the 'mdadm --create' command.


(Entering ... won't hurt BTW. mdadm will answer someting which basically means 'sorry, don't know what you mean')


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 14. August 2018, 15:13 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
I tried now several days to find out the correct commands. But I'm totally confused. As I'm a Windows user I don't get the usage of the commands. I'm really sorry, but I don't get the correct command line.

Can someone please help me and give me the correct command line?

Thank you in advance.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Samstag 18. August 2018, 12:06 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
h0tic3 hat geschrieben:
Can someone please help me and give me the correct command line?

Hast sich was geändert ?
Kannst du mir die Ausgabe von

Code:
cat /proc/mdstat
mdadm --examine /dev/sd[a-d]3

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 19. August 2018, 18:50 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Gerne.

BusyBox v1.19.4 (2018-05-22 01:23:15 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : inactive sda3[0](S) sdc3[4](S) sdb3[1](S)
17569173504 blocks super 1.2

md1 : active raid1 sdc2[6] sdb2[5] sda2[4] sdd2[7]
1998784 blocks super 1.2 [4/4] [UUUU]

md0 : active raid1 sdc1[6] sdb1[5] sda1[4] sdd1[7]
1997760 blocks super 1.2 [4/4] [UUUU]

unused devices: <none>
~ # mdadm --examine /dev/sd[a-d]3
/dev/sda3:
Magic : a92b4efc
Version : 1.2
Feature Map : 0x0
Array UUID : ead2a518:c1ac45dd:f6312324:3efd4d36
Name : NAS540:2 (local to host NAS540)
Creation Time : Wed Sep 28 19:16:21 2016
Raid Level : raid5
Raid Devices : 4

Avail Dev Size : 11712782336 (5585.09 GiB 5996.94 GB)
Array Size : 17569173504 (16755.27 GiB 17990.83 GB)
Data Offset : 262144 sectors
Super Offset : 8 sectors
State : clean
Device UUID : 5cd3ab7b:3a8b23c1:6ea7d6ce:fcc918c8

Update Time : Tue Jul 17 06:20:27 2018
Checksum : 5c199236 - correct
Events : 3176

Layout : left-symmetric
Chunk Size : 64K

Device Role : Active device 0
Array State : AA.. ('A' == active, '.' == missing)
/dev/sdb3:
Magic : a92b4efc
Version : 1.2
Feature Map : 0x0
Array UUID : ead2a518:c1ac45dd:f6312324:3efd4d36
Name : NAS540:2 (local to host NAS540)
Creation Time : Wed Sep 28 19:16:21 2016
Raid Level : raid5
Raid Devices : 4

Avail Dev Size : 11712782336 (5585.09 GiB 5996.94 GB)
Array Size : 17569173504 (16755.27 GiB 17990.83 GB)
Data Offset : 262144 sectors
Super Offset : 8 sectors
State : clean
Device UUID : a6b9a891:37ea35b6:7b80f95f:ce9c2cba

Update Time : Tue Jul 17 06:20:27 2018
Checksum : ea5f835c - correct
Events : 3176

Layout : left-symmetric
Chunk Size : 64K

Device Role : Active device 1
Array State : AA.. ('A' == active, '.' == missing)
/dev/sdc3:
Magic : a92b4efc
Version : 1.2
Feature Map : 0x0
Array UUID : ead2a518:c1ac45dd:f6312324:3efd4d36
Name : NAS540:2 (local to host NAS540)
Creation Time : Wed Sep 28 19:16:21 2016
Raid Level : raid5
Raid Devices : 4

Avail Dev Size : 11712782336 (5585.09 GiB 5996.94 GB)
Array Size : 17569173504 (16755.27 GiB 17990.83 GB)
Data Offset : 262144 sectors
Super Offset : 8 sectors
State : clean
Device UUID : d6517c2c:62e548fa:ddd85929:0a425693

Update Time : Tue Jul 17 06:20:27 2018
Checksum : 6bd01458 - correct
Events : 3176

Layout : left-symmetric
Chunk Size : 64K

Device Role : spare
Array State : AA.. ('A' == active, '.' == missing)
mdadm: No md superblock detected on /dev/sdd3.
~ #

Ich hoffe damit kann jemand was anfangen, ich leider nicht wirklich. Bin voll der noob in Linux und so.

Danke


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 26. August 2018, 17:41 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Keiner ne Idee?


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 27. August 2018, 14:33 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
doch schon ...
Jetzt ist es wieder kühler und ich kann anfangen mein backlog aufzuarbeiten ...

Erstmal ein
Code:
mdadm --stop /dev/md2

Hier könnte ein Fehler kommen, da ich es noch nie mit einem RAID5 mit 3 Spare Disks zu tun hatte, da auch noch inaktiv ist. Auch möchte ich sicherstellen, das das Datenarray nicht am laufen ist.

Dann
Code:
mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 -metadata=1.2 --chunk=64K --layout=left-symmetric /dev/sd[a-c]3 missing

s/none/missing/

Es wird ein RAID5 neu errzeugt und angenommen, das es "sauber" ist, d.h. es werden die RAID Informationen nur so weit upgedated wie nötig. Die Daten(inhalte) werden nicht angefasst.

Deine Raidinfo aus
Code:
# cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md3 : inactive sda3[0](S) sdc3[4](S) sdb3[1](S)
17569173504 blocks super 1.2

Ist etwas wirr. Index 0,4, und 1
Danach bitte mal einen Filesystemcheck machen
mit
Zitat:
e2fsck -n /dev/md2

Es wird nur "Readonly" gemacht.
Hier bitte die Ausgabe posten, die ersten 10-20 Zeilen reichen.

Was mich aktuell etwas stutzig macht ist die Größe deines RAID5
Hast du wirklich 4 * 6TB Platten am Start ?
Wenn ja mit welcher Firmware ?

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 27. August 2018, 22:28 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Wie geil, danke dir vielmals für deine Zeit und Mühe. Leider hat der zweite Code nicht geklappt. Dazu hier der komplette Output:
BusyBox v1.19.4 (2018-05-22 01:23:15 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # mdadm --stop /dev/md2
mdadm: stopped /dev/md2
~ # mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 -metadata=1.2 --chunk=64K --la
yout=left-symmetric /dev/sd[a-c]3 none
mdadm: option -m not valid in create mode
~ #

Zu deiner Frage, ja ich habe 4+6TB Platten von WD Red verbaut. Alle Mit der NASware 3.2.

Ich habe mir mal was gegönnt. Hatte lange gespart und so. Und jetzt bin ich natürlich echt am Arsch weil da nun fast 10 TB an gesammelten Fotos, Dokumenten, usw. weg sind. Habe mir auch gleich direkt noch ein paar exteren Platten gekauft um die wichtigsten Daten noch zusätzlich zu sichern damit ich wenigstens etwas wieder zurück habe.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 28. August 2018, 09:19 
Offline
Open Source Hero

Registriert: Dienstag 24. Juni 2008, 10:33
Beiträge: 2282
h0tic3 hat geschrieben:
Code:
~ # mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 -metadata=1.2 --chunk=64K --la
yout=left-symmetric /dev/sd[a-c]3 none
mdadm: option -m not valid in create mode
~ #
That's the -m from -metadata. That should be --metadata


Nach oben
 Profil  
 
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 126 Beiträge ]  Gehe zu Seite Vorherige  1, 2, 3, 4, 5 ... 9  Nächste

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder: Exabot [Bot], Google [Bot], Google Adsense [Bot]


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de


Impressum


Hubwagen  - Hubtisch  - Hochhubwagen  - günstige Hubwagen  - Hubwagen  - Hubtisch  - Scherenhubtische  - günstige Kehrmaschinen