Zyxel Deutschland Forum - Herzlich Willkommen!

Für Support Anfragen nutzen Sie http://support.zyxel.eu oder als Fachhändler http://partner.zyxel.eu
Aktuelle Zeit: Dienstag 23. Oktober 2018, 11:30

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]



 

Forumsregeln


Achtung: FFP ist eine Zusatzanwendung, für die ZyXEL keinen Support übernimmt!
Sämtliche Support Anfragen zu FFP Produkten werden nicht bearbeitet.
Bei Fragen zu FFP wenden Sie sich am besten in Englisch an unser Forum oder an http://forum.nas-central.org/viewforum.php?f=21



Ein neues Thema erstellen Auf das Thema antworten  [ 126 Beiträge ]  Gehe zu Seite Vorherige  1 ... 5, 6, 7, 8, 9  Nächste
Autor Nachricht
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Mittwoch 19. September 2018, 10:01 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
h0tic3 hat geschrieben:
Werde ich morgen mal machen. Aber da morgen früh der Strom abgestellt wird werde ich das NAS erstmal ausschalten.

Das ja dann *alle* laufen Einstellungen "verloren" gehen
kannst du ja problemlos die vierte Platte herausziehen
.. also die ganz Rechte.

den dmesg Kram kannst du dann auch "vergessen"

Im Prinzip fangen wir von vorne an.

Und bevor ich es vergesse :
mach bitte per Klebeband oder so, von
*außen* an allen Platten eine Nummer dran.

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 24. September 2018, 09:51 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Also ich habe die vierte Platte jetzt entfernt. Zum Glück muss ich nichts markieren. Jede Platte hat einen Sticker drauf welche Platte es ist, die Trays auch. Direkt vor der Installation gemacht. Damit sowas jetzt nicht gemacht werden muss.

Also jetzt heißt es für mich das NAS ganz normal starten, eventuell das piepen deaktivieren und dann die ganzen Schritte erneut durchzuführen die zuletzt gemacht wurden. Richtig?


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Mittwoch 26. September 2018, 19:57 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
h0tic3 hat geschrieben:
Also ich habe die vierte Platte jetzt entfernt. Zum Glück muss ich nichts markieren. Jede Platte hat einen Sticker drauf welche Platte es ist, die Trays auch. Direkt vor der Installation gemacht. Damit sowas jetzt nicht gemacht werden muss.

Also jetzt heißt es für mich das NAS ganz normal starten, eventuell das piepen deaktivieren und dann die ganzen Schritte erneut durchzuführen die zuletzt gemacht wurden. Richtig?


Das Piepen würde ich deaktivieren,
den Rest würde ich nicht machen
.. da lässt man sich gerne in die Ecke manövrieren
und sucht nach Fehlern die vom Anfang an da waren.

Besonders wenn man von "NULL" Ausschalten usw. beginnt.

Nach dem Piepen erstmal den "aktuellen" Status mit
Code:
cat /proc/mdstat
cat /proc/mounts
cat /proc/partitions

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Donnerstag 27. September 2018, 17:58 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
OK, also dann bin ich jetzt genau hier:
Code:
BusyBox v1.19.4 (2018-05-22 01:23:15 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ # buzzerc -s && mv /sbin/buzzerc /sbin/buzzerc.old
~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sda3[0] sdc3[2](F) sdb3[1]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/2] [UU__]

md1 : active raid1 sdc2[6] sdb2[5] sda2[4]
      1998784 blocks super 1.2 [4/3] [U_UU]

md0 : active raid1 sdc1[6] sdb1[5] sda1[4]
      1997760 blocks super 1.2 [4/3] [U_UU]

unused devices: <none>
~ # cat /proc/mounts
rootfs / rootfs rw 0 0
/proc /proc proc rw,relatime 0 0
/sys /sys sysfs rw,relatime 0 0
none /proc/bus/usb usbfs rw,relatime 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
ubi5:ubi_rootfs1 /firmware/mnt/nand ubifs ro,relatime 0 0
/dev/md0 /firmware/mnt/sysdisk ext4 ro,relatime,user_xattr,barrier=1,data=ordered 0 0
/dev/loop0 /ram_bin ext2 ro,relatime,user_xattr,barrier=1 0 0
/dev/loop0 /usr ext2 ro,relatime,user_xattr,barrier=1 0 0
/dev/loop0 /lib/security ext2 ro,relatime,user_xattr,barrier=1 0 0
/dev/loop0 /lib/modules ext2 ro,relatime,user_xattr,barrier=1 0 0
/dev/loop0 /lib/locale ext2 ro,relatime,user_xattr,barrier=1 0 0
/dev/ram0 /tmp/tmpfs tmpfs rw,relatime,size=5120k 0 0
/dev/ram0 /usr/local/etc tmpfs rw,relatime,size=5120k 0 0
ubi3:ubi_config /etc/zyxel ubifs rw,relatime 0 0
/dev/mapper/vg_ead2a518-lv_6093c7bb /i-data/6093c7bb ext4 ro,noatime,user_xattr,barrier=1,stripe=48,data=ordered,usrquota 0 0
/dev/mapper/vg_ead2a518-vg_info_area /mnt/vg_info_area/vg_ead2a518 ext4 rw,relatime,user_xattr,barrier=1,stripe=48,data=ordered 0 0
configfs /sys/kernel/config configfs rw,relatime 0 0
~ # cat /proc/partitions
major minor  #blocks  name

   7        0     147456 loop0
  31        0        256 mtdblock0
  31        1        512 mtdblock1
  31        2        256 mtdblock2
  31        3      10240 mtdblock3
  31        4      10240 mtdblock4
  31        5     112640 mtdblock5
  31        6      10240 mtdblock6
  31        7     112640 mtdblock7
  31        8       6144 mtdblock8
   8        0 5860522584 sda
   8        1    1998848 sda1
   8        2    1999872 sda2
   8        3 5856522240 sda3
   8       32 5860522584 sdc
   8       33    1998848 sdc1
   8       34    1999872 sdc2
   8       35 5856522240 sdc3
   8       16 5860522584 sdb
   8       17    1998848 sdb1
   8       18    1999872 sdb2
   8       19 5856522240 sdb3
  31        9     102424 mtdblock9
   9        0    1997760 md0
   9        1    1998784 md1
  31       10       4464 mtdblock10
   9        2 17569172928 md2
 253        0     102400 dm-0
 253        1 17178820608 dm-1
~ #


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Samstag 29. September 2018, 11:42 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
h0tic3 hat geschrieben:
OK, also dann bin ich jetzt genau hier:
Code:
~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sda3[0] sdc3[2](F) sdb3[1]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/2] [UU__]

unused devices: <none>
~ # cat /proc/mounts
/dev/mapper/vg_ead2a518-lv_6093c7bb /i-data/6093c7bb ext4 ro,noatime,user_xattr,barrier=1,stripe=48,data=ordered,usrquota 0 0
/dev/mapper/vg_ead2a518-vg_info_area /mnt/vg_info_area/vg_ead2a518 ext4 rw,relatime,user_xattr,barrier=1,stripe=48,data=ordered 0 0

~ # cat /proc/partitions
major minor  #blocks  name

   8        0 5860522584 sda
   8        1    1998848 sda1
   8        2    1999872 sda2
   8        3 5856522240 sda3

   8       32 5860522584 sdc
   8       33    1998848 sdc1
   8       34    1999872 sdc2
   8       35 5856522240 sdc3

   8       16 5860522584 sdb
   8       17    1998848 sdb1
   8       18    1999872 sdb2
   8       19 5856522240 sdb3



Quasi wie vor dem Ausschalten ...
inkl. unvollständigem RAID5 (*)

md2 : active raid5 sda3[0] sdc3[2](F) sdb3[1]
muss mal überlegen vielleicht muss ich die RAID Superblocks löschen.
.. sollte eigentlich nicht nötig sein, aber ...

(*)
Was mich immer noch wundert, das das LVM was auf dem RAID5 aufliegt, den Fehler nicht weiterreicht, seltsam.
... wird mal debuged zur nächaten Jahrtausendwende

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 30. September 2018, 16:02 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
So jetzt gehts los (hoffentlich)

Ich kopiere der einfachheit mal einige meiner Befehle aus dem Thread hier
mdadm Überwachung aus
Code:
kill $(pgrep mdadm)

Zyxel Hotplug addons aus
Code:
sed "/hotplug/d" -i /etc/mdev.conf
echo > /proc/sys/kernel/hotplug
echo /sbin/mdev > /proc/sys/kernel/hotplug

Hintergrundprocezze killen
Code:
for p in $(lsof -n | grep 6093c7b | awk '{ print $2}' | sort | uniq); do
   kill $p; sleep 1; kill -9 $p;
done

LVM unmounten und aus
Code:
umount /i-data/6093c7bb
umount /mnt/vg_info_area/vg_ead2a518
vgchange -a n

RAID5 aus
Code:
mdadm --stop /dev/md2

RAID Superblöcke löschen
Code:
mdadm --zero-superblock /dev/sd[abc]3

Das löscht nur die Superblöcke und nicht die Daten

RAID wieder aufbauen
Code:
mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 --metadata=1.2 --chunk=64K --layout=left-symmetric /dev/sd[a-c]3 none

Jetzt bitte mal ein
Code:
cat /proc/mdstat

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 1. Oktober 2018, 15:23 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Der hängt irgendwie hier fest:
Code:
~ # mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 --metadata=1.2 --chunk=64K --l
ayout=left-symmetric /dev/sd[a-c]3 none
mdadm: cannot open none: No such file or directory
~ #


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 1. Oktober 2018, 16:50 
Offline
Open Source Hero

Registriert: Dienstag 24. Juni 2008, 10:33
Beiträge: 2282
'none' should be 'missing'


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 1. Oktober 2018, 18:53 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
Mijzelf hat geschrieben:
'none' should be 'missing'

und damit ich nicht schon wieder auf den Fehler hereinfalle
habe ich mal (hoffentlich) alle Post hier geändert ...

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Freitag 5. Oktober 2018, 18:08 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
OK, ich bin jetzt ein wenig extrem verwirrt. Also soll ich jetzt bei den Befehlen "missing" anstatt "none" eintragen?

In den Posts sehe ich nämlich keine Änderung. Darum weiß ich nicht was jetzt gemacht werden kann/soll.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Samstag 6. Oktober 2018, 14:35 
Offline
engagiertes Mitglied

Registriert: Dienstag 17. September 2013, 20:13
Beiträge: 370
Falsch:
Zitat:
mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 --metadata=1.2 --chunk=64K --layout=left-symmetric /dev/sd[a-c]3 none

Richtig:
Zitat:
mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 --metadata=1.2 --chunk=64K --layout=left-symmetric /dev/sd[a-c]3 missing


So schwer ist das nicht... :pirat:


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Sonntag 7. Oktober 2018, 02:03 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
ElektromAn hat geschrieben:
Mijzelf hat geschrieben:
'none' should be 'missing'

und damit ich nicht schon wieder auf den Fehler hereinfalle
habe ich mal (hoffentlich) alle Post hier geändert ...


Meine nur deswegen. Sorry, aber ich bin wirklich gar nicht in der Materie drinne und bevor ich was falsch mache frage ich lieber nach.


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Montag 8. Oktober 2018, 17:19 
Offline
interessiertes Mitglied

Registriert: Samstag 8. August 2015, 10:50
Beiträge: 60
Also nachdem ich das none durch missing ersetzt habe bin ich jetzt hier:
Code:
~ # mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 --metadata=1.2 --chunk=64K --l
ayout=left-symmetric /dev/sd[a-c]3 missing
mdadm: array /dev/md2 started.
~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sdc3[2] sdb3[1] sda3[0]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/3] [UUU_]

md1 : active raid1 sdc2[6] sdb2[5] sda2[4]
      1998784 blocks super 1.2 [4/3] [U_UU]

md0 : active raid1 sdc1[6] sdb1[5] sda1[4]
      1997760 blocks super 1.2 [4/3] [U_UU]

unused devices: <none>
~ #


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 9. Oktober 2018, 20:12 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
h0tic3 hat geschrieben:
Meine nur deswegen. Sorry, aber ich bin wirklich gar nicht in der Materie drinne und bevor ich was falsch mache frage ich lieber nach.

No Problem ...
h0tic3 hat geschrieben:
Also nachdem ich das none durch missing ersetzt habe bin ich jetzt hier:
Code:
~ # mdadm --create /dev/md2 --assume-clean --level=5 --raid-devices=4 --metadata=1.2 --chunk=64K --l
ayout=left-symmetric /dev/sd[a-c]3 missing
mdadm: array /dev/md2 started.
~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid5 sdc3[2] sdb3[1] sda3[0]
      17569172928 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/3] [UUU_]
~ #

Sieht schon mal *gut* aus.

Alle Partitionen sauber im RAID drin und der Index stimmt auch.
... jetzt such ich noch den Post mit dem Index innerhalb vom LVM ...

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
 Betreff des Beitrags: Re: Auch NAS540 RAID5 Problem
BeitragVerfasst: Dienstag 9. Oktober 2018, 20:44 
Offline
Experte

Registriert: Dienstag 19. Mai 2015, 09:25
Beiträge: 710
Wohnort: Germany / Cologne
So

leeres Verzeichnis, zum mounten
Code:
mkdir /mnt/raid5

in das ext4 vom LVM springen
Code:
losetup -o $((64*1024)) /dev/loop1 /dev/md2

kleiner Filesystem test
Code:
e2fsck -n /dev/loop1

als READ only mouten
Code:
mount /dev/loop1 /mnt/raid5 -r

und sehen was da ist
Code:
ls -lR /mnt/raid5


Wenn du willst kannst du auch prüfen ob die Daten lesbar sind
Code:
tar cvf /dev/null /mnt/raid5

Die letzten beiden Ausgabe sind logischerweise nur für dich ...
Das erzeugt ein tar Archive, speichert dieses in den digitalen Mülleimer /dev/null
gibt mir aber eine Fileliste aus

_________________
Linux Kernel Developer
Lots of stuff attached to serial console
https://github.com/ulli-kroll


Nach oben
 Profil  
 
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 126 Beiträge ]  Gehe zu Seite Vorherige  1 ... 5, 6, 7, 8, 9  Nächste

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder: Exabot [Bot]


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de


Impressum


Hubwagen  - Hubtisch  - Hochhubwagen  - günstige Hubwagen  - Hubwagen  - Hubtisch  - Scherenhubtische  - günstige Kehrmaschinen